Technical informaiton about playing videos on royalsociety.tv

Adobe Flash player

The video player for recorded events requires Adobe Flash version 10.1 or above.

Javascript

The video player requires Javascript, which is used to synchronise the slides and video.

Please ensure that your browser has Javascript turned on. Instructions for doing this can be found in your browser’s help pages (press F1).

Further help

Please contact us if you experience problems accessing live or recorded videos of our events.